Jump to content

Driver catch 22


Recommended Posts


Does anyone at hardware manufacturers think about what they are doing before they release drivers?

The workstation I've been trying to configure has a 3Com NIC. The NIC is not recognized by either Win98 or W2K pro.

OK, this by itself is not such a big deal.

The driver included with the NIC, also does not work. Its not compatible with the Intel 820 chipset. The driver that does work needs to be downloaded from 3Com's website. The driver is packaged in such a way as it is intended to be run from the website as an executable.

Now this poses a slight problem in that I need the NIC, to access the DSL modem, to access the website, to install the driver.

Hello, 3Com, is there anybody home?

Now if I was a hardware manufacturer and I learned that Intel was shipping some new chipsets, I might try to make a driver with some simple .ini files that could be discovered by Windows. Then I could use another system to download the files and copy them to a floppy. As is I'm going to have to download the files in any event and play with it until it works. 3Com says your not supposed to do that. Well, duh.

I wouldn't even hope to have them send a new CD as that would require an actual cost for them.

Oh joy.

Link to post
Share on other sites


Its packaged two ways: a) a self extracting executable that can be downloaded - of which I already have a copy, more on this, and B) as an automatically installing program run directly from their site, much like Microsofts update site.

When I run program "a)" the files self extract just as advertised. However when I attempt to run the install executable several things go wrong. These mainly deal with missing .dll and .ini files. Now the .dll files are referenced as being located on the W2K CD. OK I do a file search for the missing .dll both on the CD as well as my system, I even try *.dll, no deal. OK its possible the file is compressed on the CD. I also know I can search Microsoft's site. If that was the only missing file I would do this. Now the missing .ini files are supposed to be included in the downloaded package. Nope. OK I can also, probably, search 3Com's site for these files.

The remote install option, much like at Microsoft's update site, works only by downloading and installing to the target system. Otherwise go back to option one and download the complete package and install manually.

The problem with this is that I'm running DSL, hence no dial-up. The ISP wants to wack me another fee for dial-up service.

The solution is to call 3Com's tech support, which is now open and quite good I might add, and have them hand feed me the files on another system that is already connected. Actually the one I'm using now.

Once I get the missing files straightened out, then I can manually configure the NIC, again getting back to the 820 chipset issue.

Then when I'm done with that its time to fire it up and see if I can get updated drivers for the rest of the incompatibility issues.

Thankfully this is not a project that needs to be done yesterday.

I just found humor in the catch 22 aspect of this dilema last night.

Once I get done with all this its time to go play with a catalyst switch.

Funny you mentioned the web server, I also have to find time for installing IIS 4.0. But that can wait.

[ May 22, 2001: Message edited by: Brink15 ]

Link to post
Share on other sites


Thanks much. I never knew that about MSs downloads. I'm going to check it out.

3Com tech support should be able to point me to the right files to get the NIC working.

I'm embarrased to say that even though I'm real comfortable with hardware and applications, I know squat about programming.

I really should learn, at least HTML and JAVA anyway.

The IIS server, once I have it configured properly, is off to a client. Let them find someone to write their web scripts.

I cheat, I have a set of scripts and macros I can pretty much cut and paste. But they all intended for administration, not web design.

I've got a copy of Dreamweaver around somewhere. Just never had time to play with it.

Link to post
Share on other sites


You'll love this. This was basically my conversation with 3Com tech support.

"Hi, I'm having a problem installing a driver for your Etherlink PCI NIC card." "What are you running?" "A PIII 733 w/ 128 megs of RD-ram and the 820 chipset. I'm using W2K as the O/S." "Hmmm. 820 chipset and W2K. Alright what is the problem?" "When I run the install program from the downloaded package it indicates there are missing .ini and .dll files." "Did you run the pre-install program?" "No the NIC was already installed in the box." "Oh, well theres your problem. You need to remove the NIC and run the preinstall program, then re-install the NIC, then install the drivers." "But when the NIC was initially installed last year there was no preinstall program and it worked fine running Win98." "Oh, well I guess you were lucky. There were so many problems with compatibility with new Intel chipsets that we had to change the installation procedures." "And I suppose you updated the installation info in the Readme file?" "Well, I'm not sure, but there is documentation seperately on the website." "Thanks for the info." "Thank you for calling 3Com."

So, all I have to do is remove the reference to the unknown PCI device in the hardware manager, uninstall the NIC, run the pre-install program, re-install the NIC, the run the install program, all the while praying.

I think I'll go light some incense, say a prayer to Luang Por Khun, and open a beer.

Link to post
Share on other sites

It sounds like your problem has been solved... I used to run into similar issues way-back-when with my old modems and various initialization string problems. Getting the appropriate information from the website isn't exactly an alternative when one's modem is FUBAR.

Good thing I had access to the Internet through other computers.

For missing .dll files, sometimes a straight search on search engines (I used to use Archie but I don't even know if it is still maintained) will bring up an FTP directory with the file sitting in there.


Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...